impossible d'installer des fichiers .deb



  • Je suis sous ubuntu et je passe par l'interface par défaut pour installer les fichiers .deb et quand je clique sur installer il me demande mon mot de passe et rien ne se passe.
    même en ligne de commande ca ne fonctionne pas : sudo dpkg -i google-gadgets-0.11.2.deb.
    (Lecture de la base de données... 245796 fichiers et répertoires déjà installés.)
    Préparation du dépaquetage de google-gadgets-0.11.2.deb ...
    Dépaquetage de google-gadgets-gtk:i386 (0.11.2-3ubuntu1) sur (0.11.2-3ubuntu1) ...
    dpkg: des problèmes de dépendances empêchent la configuration de google-gadgets-gtk:i386 :
    google-gadgets-gtk:i386 dépend de google-gadgets-common (= 0.11.2-3ubuntu1).
    google-gadgets-gtk:i386 dépend de google-gadgets-gst (= 0.11.2-3ubuntu1).
    google-gadgets-gtk:i386 dépend de google-gadgets-xul (= 0.11.2-3ubuntu1).
    google-gadgets-gtk:i386 dépend de libatk1.0-0 (>= 1.29.3).
    google-gadgets-gtk:i386 dépend de libcairo2 (>= 1.2.4).
    google-gadgets-gtk:i386 dépend de libfontconfig1 (>= 2.8.0).
    google-gadgets-gtk:i386 dépend de libfreetype6 (>= 2.2.1).
    google-gadgets-gtk:i386 dépend de libgdk-pixbuf2.0-0 (>= 2.21.6).
    google-gadgets-gtk:i386 dépend de libggadget-1.0-0b (>= 0.11.2).
    google-gadgets-gtk:i386 dépend de libggadget-gtk-1.0-0b (>= 0.11.2).
    google-gadgets-gtk:i386 dépend de libglib2.0-0 (>= 2.16.0).
    google-gadgets-gtk:i386 dépend de libgtk2.0-0 (>= 2.10.0).
    google-gadgets-gtk:i386 dépend de libpango1.0-0 (>= 1.18.0).

    dpkg: erreur de traitement du paquet google-gadgets-gtk:i386 (--install) :
    problèmes de dépendances - laissé non configuré
    Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-11ubuntu1.1) ...
    Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
    Traitement des actions différées (« triggers ») pour mime-support (3.60ubuntu1) ...
    Traitement des actions différées (« triggers ») pour man-db (2.8.3-2ubuntu0.1) ...
    Des erreurs ont été rencontrées pendant l'exécution :
    google-gadgets-gtk:i386

    J'ai essayé gdebi-gtk il me répond dépendances cassées votre systeme a des dépendance cassées. JE ne sais plus quoi faire. Aidez-moi. Merci d'avance.


  • Membre

    bonjour ,
    il te manque des dependances.
    ouvre un terminal et rentre cette commande:
    sudo apt -f install



  • merci. JE vais essayer et te tiens au courant. LA pour le moment je télécharge ubuntu pour le réinstaller. Mais je vais essayer ta commande avant.



  • ca ne fonctionne pas.


  • Membre

    il y a quoi comme erreur ?



  • Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
    amarok-common emacs25 emacs25-bin-common emacs25-common emacs25-el
    filezilla-common fonts-dejavu fonts-dejavu-extra icoutils kde-runtime
    kde-runtime-data kde-style-breeze kde-style-breeze-qt4 kdelibs-bin
    kdelibs5-data kdelibs5-plugins kdemultimedia-kio-plugins kdoctools kinit kio
    kio-audiocd libaio1 libattica0.4 libcrypto++6 libdbusmenu-qt2
    libdlrestrictions1 libfilezilla0 libftgl2 libglew2.0 libgpgme++2v5
    libhfstospell9 libkactivities6 libkcmutils4 libkde3support4 libkdeclarative5
    libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4
    libkf5attica5 libkf5bookmarks-data libkf5bookmarks5 libkf5cddb-data
    libkf5cddb5 libkf5compactdisc-data libkf5compactdisc5 libkf5completion-data
    libkf5completion5 libkf5doctools5 libkf5globalaccel-bin
    libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5
    libkf5jobwidgets-data libkf5jobwidgets5 libkf5kdelibs4support-data
    libkf5kdelibs4support5 libkf5kdelibs4support5-bin libkf5kiocore5
    libkf5kiofilewidgets5 libkf5kiontlm5 libkf5kiowidgets5 libkf5parts-data
    libkf5parts-plugins libkf5parts5 libkf5solid5 libkf5solid5-data
    libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5style5
    libkf5textwidgets-data libkf5textwidgets5 libkf5xmlgui-bin libkf5xmlgui-data
    libkf5xmlgui5 libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4
    libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4
    libkpty4 libkrosscore4 libktexteditor4 libkxmlrpcclient4 liblastfm1
    liblockfile-bin liblockfile1 libm17n-0 libmusicbrainz5cc2v5 libmygpo-qt1
    libmysqlclient20 libnl-route-3-200 libntrack-qt4-1 libntrack0 libofa0
    libotf0 libphonon4 libplasma3 libpolkit-qt-1-1 libprojectm2v5 libpugixml1v5
    libqca2 libqca2-plugins libqjson0 libqt4-dbus libqt4-declarative
    libqt4-designer libqt4-network libqt4-opengl libqt4-qt3support libqt4-script
    libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg
    libqt4-xml libqt4-xmlpatterns libqt5test5 libqtcore4 libqtdbus4 libqtgui4
    libqtscript4-core libqtscript4-gui libqtscript4-network libqtscript4-sql
    libqtscript4-uitools libqtscript4-xml libqtwebkit4 libqxt-core0 libqxt-gui0
    libsolid4 libstreamanalyzer0v5 libstreams0v5 libtag-extras1 libthreadweaver4
    libutempter0 libvoikko1 m17n-db mysql-common ntrack-module-libnl-0
    oxygen-icon-theme phonon phonon-backend-gstreamer
    phonon-backend-gstreamer-common plasma-scriptengine-javascript projectm-data
    qdbus qt-at-spi qtchooser qtcore4-l10n sonnet-plugins
    Veuillez utiliser « sudo apt autoremove » pour les supprimer.
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

    JE ne comprends rien.


  • Membre

    c 'est juste des paquets qui ne servent plus a rien. (Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires)
    Ton paquet que tu essaye d' installer n'a pas les librairies (libatk1.0-0,etc..) , donc pas installable.
    si tu veut des widgets va voir de ce coté la :
    https://doc.ubuntu-fr.org/screenlets
    ça pourrai peut etre t'interresser.
    on ne sait jamais ,que donne la commande ?
    sudo apt update && apt-cache search google-gadgets


  • Membre

    Ne serait-ce pas un problème de paquets plus récents dans une distribution par rapport à l'autre ?


  • Membre

    les sources du paquet sont la:
    https://code.google.com/archive/p/google-gadgets-for-linux/downloads
    le guide pour le compiler:
    https://code.google.com/archive/p/google-gadgets-for-linux/wikis/HowToBuild.wiki
    les sources : Jan 27, 2010
    le guide : Ubuntu 8.04 and 8.10 series
    je pense vraiment qu'il y aura un probléme de dépendance.


  • Membre

    @livrecinq a dit dans impossible d'installer des fichiers .deb :

    Ne serait-ce pas un problème de paquets plus récents dans une distribution par rapport à l'autre ?

    @e1415 a dit dans impossible d'installer des fichiers .deb :

    les sources : Jan 27, 2010
    le guide : Ubuntu 8.04 and 8.10 series

    Ubuntu sort une LTS tous les 2 ans !


  • Membre

    @MrTidy a dit dans impossible d'installer des fichiers .deb :

    LA pour le moment je télécharge ubuntu pour le réinstaller.

    Très bonne idée ! Et si besoin d'une version 32 bits alors se tourner vers lubuntu/xubuntu.



  • @e1415 J'ai bien lancé ta commande tout s'est bien passé. Mais par contre d'être si nul, je ne sais pas lancer le programme je ne le trouve pas. J4ai charché dans synaptic il ne me le trouve pas.

    @Olivier J'ai insatllé 3 fois ubuntu et j'ai le même problème. Les .deb qui s'inaller parfaitement c'est quand je passe par le logiciel ubuntu. Elle plante uniquement sur les .deb téléchargés. Mais je ne vais pas attendre 2 ans. Je me remets tout juste à linux parce que ça me pationne. J'ai résolu pas mal de soucis. Mais il me les fichiers deb qui deviennent handicapant.

    @livrecinq Je ne sais pas. J'ai réinstallé 3 fois ubuntu je n'avais pas le problème la 1ere fois. J'avais d'autres soucis qui sont résolu. Mais là c'est handicapant de ne pas pouvoir installer des deb.

    @e1415 Je n'arrive pas a lancer google-gadgets.

    @livrecinq Je ne sais pas j'utiliser la version unbuntu 18.4.1. Est-ce quelqu'un rencontre les même soucis que moi.

    @e1415 J'ai désinstallé les paquets qui ne servent plus. Ca ne marche pas non plus. Merci pour ton aide.

    @Olivier J'ai oublié de préciser que mon fichier fstab est vierge.

    @e1415 J'ai oublié de préciser que mon fichier fstab est vierge.

    @MrTidy Mes partitions ntfs sont monté.

    @Olivier J'ai déjà insallé 3 fois ubuntu.

    @livrecinq Comment je peux le savoir. Surtout que j'ai réussi a installer google chrome, teamviewer et spotify et depuis ca ne fonctionne pas.


  • Membre

    @e1415 a dit dans impossible d'installer des fichiers .deb :

    apt-cache search google-gadgets : cette commande cherche dans les depots si google-gagets existe.
    elle n'installe rien du tout.
    si il est dans les dépots tu l' install avec:
    sudo apt install google-gadgets(mais ne doit pas etre dans les dépots vu que synaptic le trouve pas)

    avant installer un .deb de je ne sais ou!!!!(toujours vérifier les sources;risque pour la machine!!!! I AM ROOT!!!!)
    les derniére sources de google-gagets date de Jan 27, 2010 .il est plus déveloper depuis longtemps.
    essaye screenlets:sudo apt install screenlets

    préférer toujours ce qu'il y a dans les dépots.(plus compatible et fonctionnelle)

    ET quand un deb télécharger ou un paquet s'installe pas,ne pas réinstaller tout le système.
    Si tu as la dernière version ubuntu.(18.04LTS,18.10)


  • Membre


  • Membre

    @MrTidy a dit dans impossible d'installer des fichiers .deb :

    Je me remets tout juste à linux parce que ça me pationne.

    C'est super ! Passe donc nous voir une prochaine fois.



  • @Olivier J'ai une tour et mon scooter est en panne.